Just InSample Library & Expansion News

OMEN – War Chants Kontakt Library Is On Offer

Silence+Other Sounds have reduced the price of OMEN, their ritual voices & war chants library which is now only €49.00, (usually $79.00). The offer ends July 17th.

Omen is a Kontakt  library based on ritual voices and epic war chants. We have recorded many traditional singing styles from different cultures around the world: Tuvan throat and overtone singing (Kaargyra, Khoomei and Szygyt), Sardinian Throat singing (Bassu), Nordic Kulning (high pitch female style), Slavic singing (white voices), Western baritone, tenor and soprano, guttural voices, ritual chants and even extreme distortion, high-pitch techniques, screams, vocal fry and growls.

The result is a set of 8 different playable Kontakt instruments that combine all these voices together to create a huge variety of sounds: from shamanic low vocal drones to mysterious rhythmic hymns, from ethereal female choirs to aggressive haka-style chants, from monk humming sounds to Viking-reminding vocal ensembles.

Omen is for TV, film , game composers and sound designers looking for a one of a kind instrument based on rare and meticulously recorded voices to immediately set a ‘dark age’ mood. It fits particularly well the epic genre, with specific regard to fantasy and dark age movies, but its versatility makes it useful also for post-horror, thriller, electronic and ambient music

Features include:

  • 8 Kontakt libraries
  • 72 Snapshots (for the Vocal Layers instrument only)
  • 46 MPE Multis (Based on the Vocal Layers instrument)
  • Convolution Reverb (24 Impulse Responses from Acoustic environments, Digital reverbs and Experimental samples)
  • Control per-sample or per -layer (according to the instrument): Volume Envelope, High Pass Filter, Low Pass Filter, Filter Resonance, LFO Rate, Amount and Shape.
  • Independent per-sample reverse function for one-shot SFX
  • Intuitive MIDI mapping for both standard MIDI as MPE (Vocal Layers only)

OMEN requires a full version of Kontakt 5.8 or later.

For more information the OMEN, click here:

NOTE: Some of the links you click on may be affiliated. Clicking and purchasing using these links helps support and fund The Beat Community. Thanks for your support.

Tags: , , , , , , , , , ,

More Similar Posts

Recent Posts